Aether 1.6.6 (1622) is now available!

This is a minor update including fixes for issues reported by users of Aether 1.6.5. This version of Aether requires OS X 10.9.5 Mavericks or later. See below for a detailed list of changes:

Changes

Disable experimental dark mode support on macOS 10.14 Mojave. An update with full support for dark mode is coming soon.

Bug Fixes

  • Fixed a bug that caused the "Needed" view in the awards window to show incorrect results

All changes since Aether 1.6.5 (1608) are listed here.